View Issue Details

IDProjectCategoryView StatusLast Update
0000010RouterOS v5[All Projects] Generalpublic2013-05-21 08:59
Reporterbutche 
Assigned Tobutche 
PrioritynormalSeverityminorReproducibilityalways
Status confirmedResolutionopen 
PlatformAllOSRouterOSOS Version5.4
Summary0000010: Simple Queues do not work with IPv6
DescriptionWhen adding a simple queue in ROS v5.4 (perhaps earlier versions as well, this has not been tested by me, yet) with an IPv6 address as the target address, the queue does not match any IPv6 traffic.
Steps To Reproduce/queue simple
add direction=both max-limit=128k/128k \
    target-addresses=2001:470:c30a:601::1/128

The queue does not see any traffic. I changed the target address to:
2001:470:c30a:601::/64 and still the queue does not manage the traffic.
I added another queue as follows:
/queue simple add packet-marks=test
/ipv6 firewall mangle
add action=mark-packet chain=prerouting disabled=no \
    new-packet-mark=test \
    passthrough=no \
    src-address=2001:470:c30a:601::1/128
add action=mark-packet chain=prerouting disabled=no \
    dst-address=2001:470:c30a:601::1/128 \
    new-packet-mark=test passthrough=no

This one sees and manages the traffic (though I obviously haven't
differentiated between up/down direction.
Additional InformationMikrotik response with workaround (Janis Krumins of MT support):

******BEGIN QUOTE******
to make simple queue work for IPv6 set argument dst-address=::/0
        
        
There is little glitch that we are looking into that when you add simple
queue, dst-address field gets a value of 0.0.0.0/0, as result, packets
are matched for IPv6-IPv4 pair. Setting IPv6 address in the dst-address
makes queue to match IPv6-IPv6.
        
        Regards,
        Janis Krumins
        
********END QUOTE*********
Tagsipv6, simple-queues

Relationships

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2011-06-07 14:05 butche New Issue
2011-06-07 14:05 butche Status new => assigned
2011-06-07 14:05 butche Assigned To => butche
2011-06-07 14:06 butche Tag Attached: simple-queues
2011-06-07 14:06 butche Tag Attached: ipv6
2011-06-07 14:08 butche Status assigned => confirmed
2013-05-21 08:59 omega-00 Platform All RouterOS 5.4 => All