View Issue Details

IDProjectCategoryView StatusLast Update
0000011RouterOS v5[All Projects] Generalpublic2011-06-09 16:40
Reporteromega-00 
Assigned Toomega-00 
PrioritynormalSeveritymajorReproducibilityrandom
Status confirmedResolutionopen 
Platformx86OSRouterOSOS Version5.4
Summary0000011: Simple queues not removed upon hotspot logout / hotspot users logged out prematurely
DescriptionTicket#2011060966000454

Reported an a problem in v5.4 where simple queues aren't always being removed when a hotspot session is terminated.

This particular site seemed to have dropped all but 2 users at the time I logged in however wouldn't allow users back online due to all the dynamic queues being still present.

==
Workaround:
==
I've made a simple workaround which checks for dynamic hotspot queues with no matching hotspot user account and removes them.

==Start of Script==
:local username
:local line

#:log info "begin queue tree loop"
:foreach line in=[/queue simple find where name!="hs-<hotspot>"] do={
  :set username [/queue simple get $line name]
  :set username [:pick $username 9 ([:len $username]-1)]
#:log info "username: $username"

:if ([/ip hotspot active find where user=$username]!="") do={} else={
/queue simple remove [/queue simple find where name="<hotspot-$hotspotuser>"]
#:log info "Removed queue for $username"
}
}
==End of Script==

Change the hs-<hotspot> and <hotspot- sections to match the hotspot server name on the router.
TagsNo tags attached.

Relationships

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2011-06-09 16:17 omega-00 New Issue
2011-06-09 16:17 omega-00 Status new => assigned
2011-06-09 16:17 omega-00 Assigned To => omega-00
2011-06-09 16:40 omega-00 Status assigned => confirmed